Skip to content
@curityio

Curity I/O

Curity I/O is an identity company that specializes in OAuth and OpenID Connect

Identity and Access Management Resources

The repositories contain multiple types of technical resource on identity topics.
Each repository has a link to a tutorial on the Curity Website.
For details on how to locate repositories, see the Using Topics documentation.

Pinned Loading

  1. nginx_phantom_token_module nginx_phantom_token_module Public

    NGINX module that introspects phantom access tokens according to RFC 7662

    Perl 71 17

  2. spa-using-curitytokenhandler spa-using-curitytokenhandler Public

    Demonstrates Hardened Security for Single Page Applications

    TypeScript 6 3

  3. cloud-native-oauth-security-examples cloud-native-oauth-security-examples Public

    End-to-end code examples for the O'Reilly book on Cloud Native Data Security with OAuth

    TypeScript 33 10

  4. curity-operational-training curity-operational-training Public

    Learn how to operate, administer and develop extensions to the Curity Identity Server

    Shell 3 1

  5. idsvr-docker idsvr-docker Public

    Docker-related files, resources, and information for the Curity Identity Server

    Dockerfile 10 3

  6. idsvr-helm idsvr-helm Public

    This repository contains the Curity Identity Server helm chart source code.

    Mustache 11 27

Repositories

Showing 10 of 218 repositories
  • ui-kit Public

    Monorepo for Self Service Portal, Login Web App, HAAPI React App, Template System, and Styles

    TypeScript 5 Apache-2.0 3 0 35 Updated Oct 3, 2026
  • ai-agents-auth-demo Public

    Runnable end-to-end AuthN/AuthZ for AI agents on Kubernetes (KIND). A DevOps copilot acts on a user's behalf over MCP, A2A and LLM hops. Each SPIFFE-identified, least-privilege via RFC 8693 token exchange (on-behalf-of), MFA-gated with RFC 9470 step-up, and traced with OpenTelemetry. Curity Identity Server · Istio · SPIRE · agentgateway.

    curityio/ai-agents-auth-demo's past year of commit activity
    TypeScript 1 Apache-2.0 0 0 0 Updated Oct 2, 2026
  • idsvr-docker Public

    Docker-related files, resources, and information for the Curity Identity Server

    curityio/idsvr-docker's past year of commit activity
    Dockerfile 10 Apache-2.0 3 0 0 Updated Oct 2, 2026
  • curityio/idsvr-docker-fips's past year of commit activity
    Shell 1 0 0 0 Updated Oct 2, 2026
  • username-password-authenticator Public

    An authenticator to customize username and password flows

    curityio/username-password-authenticator's past year of commit activity
    Java 6 Apache-2.0 1 0 0 Updated Oct 1, 2026
  • curity-plugin-sdk-skill Public

    Instructions for coding agents to implement plugins that extend the Curity Identity Server

    curityio/curity-plugin-sdk-skill's past year of commit activity
    0 0 0 0 Updated Oct 1, 2026
  • ietf-draft-oauth-client-challenge-protocol Public

    A draft specification at IETF that defines how to challenge an OAuth client to provide more data in its next request to the Authorization Server.

    curityio/ietf-draft-oauth-client-challenge-protocol's past year of commit activity
    Makefile 0 0 4 0 Updated Oct 1, 2026
  • ios-idsvr-haapi-driver-dist Public

    Distribution of the iOS Hypermedia Authentication API (HAAPI) DRIVER for the Curity Identity Server

    curityio/ios-idsvr-haapi-driver-dist's past year of commit activity
    Objective-C 2 0 0 0 Updated Sep 30, 2026
  • curityio/ios-idsvr-haapi-ui-kit-dist's past year of commit activity
    Objective-C 0 0 0 1 Updated Sep 30, 2026
  • ios-idsvr-haapi-sdk-dist Public

    Distribution of the iOS Hypermedia Authentication API (HAAPI) SDK for the Curity Identity Server

    curityio/ios-idsvr-haapi-sdk-dist's past year of commit activity
    Objective-C 8 0 0 0 Updated Sep 30, 2026